FANDOM


To use PySwarm, you will first need to download and install:

  • Python, a programming language needed for PySwarm
  • PyCarrara, a plug-in for Carrara
  • The latest version of PySwarm

The Python Programming LanguageEdit

NOTE: If you already have Python installed on your computer, you can skip this section of the guide.

First download Python 2.6.6.

If you are using the 32-bit (not x64) versions of either Carrara 8.1 or 8.5, use this link: http://www.python.org/ftp/python/2.6.6/python-2.6.6.msi

If you are using the 64-bit versions of either Carrara 8.1 or 8.5, use this link: http://www.python.org/ftp/python/2.6.6/python-2.6.6.amd64.msi

Once it is downloaded, run the installer. This should complete the installation.

For troubleshooting problem with the Python installation, read more by going here.

NOTE: There are later versions of Python available, but I have not tested whether they work properly with PyCarrara (nor, as I understand, has the developer of PyCarrara).

The PyCarrara Plug-In for CarraraEdit

NOTE: If you already have the PyCarrara V1.0 plug-in installed on your computer, you can skip this section of the installation.

After you have installed Python, you will need to download and install the latest version of the PyCarrara plug-in for Carrara. You can find this on SourceForge at: http://sourceforge.net/projects/pycarrara/files/

Choose the file “PyCarrara-Win-1.0.zip” to download.

Once downloaded, save the unzipped contents to a folder. Then make sure you do not have Carrara running.

To install the plug-in (so Carrara can use the PyCarrara features needed by PySwarm), you will need to copy (drag and drop) the following files to your Carrara directories:

  • If you are using the 32-bit version of Carrara 8.1 or 8.5 - Copy the contents of the folder “C8_Win32/Extensions” (the files, not the folder) into “C:/Program Files (x86)/DAZ 3D/Carrara 8.1/Extensions” (or wherever you installed Carrara). This should include 3 files (a .TXT file, a .DAT file, and a .MCX file) and a folder named "plugins".
  • If you are using the 64-bit version of Carrara 8.1 or 8.5 - Copy the contents of the folder “C8_x64/Extensions” (the files, not the folder)  into “C:/Program Files/DAZ 3D/Carrara8.5/Extensions” (or wherever you installed Carrara x64). This should include 3 files (a .TXT file, a .DAT file, and a .MCX file) and a folder named "plugins".

The same version of Python and PyCarrara work with both Carrara 8.1 and 8.5. The difference is in whether you are using a 32-bit or 64-bit operating system and Carrara. You can verify PyCarrara is correctly installed by following these steps:

  1. Start Carrara
  2. Open any Carrara scene (or create a new one)
  3. Add or select any object in the scene
  4. Go to the "Modifiers" tab and click "+"
  5. If "PyModifier" is in the drop-down list of modifiers, then PyCarrara should be installed and working.

For troubleshooting problem with the PyCarrara installation, read more by going here.

Latest Version of the PySwarm PackageEdit

The latest version of PySwarm is V0.6.

You can download the PySwarm V0.6 Installer with the following link:

https://drive.google.com/file/d/0B8V9-txK8F4MZk41MElqR0xPbEk/edit?usp=sharing

Select “Download” under "File". You can run the installer directly from your download directory.

Note: If you are unable to download an executable file, you can download a .ZIP version and unzip the installer:

https://drive.google.com/file/d/0B8V9-txK8F4McVJhWXJkcE9ibVE/edit?usp=sharing

For detailed instructions on how to install and uninstall PySwarm, go to the following wiki page: here.

PySwarm Version Release HistoryEdit

  • 0.3: Initial release (10/25/2013)
  • 0.3.1: Bug fix when no camera or focus are used (10/25/2013)
  • 0.3.2: Bug fix when using “Attractor” object (10/29/2013)
  • 0.4: New features added (11/04/2013)
  • 0.4.1: Four bug fixes (11/18/2013)
  • 0.4.2: Slight enhancements (12/11/2013)
  • 0.5: New features along with the release of PIA V1.0 (12/29/2013)
  • 0.5.1: Several bug fixes (01/02/2014)
  • 0.5.2: Added a few display features while importing scripts and several bug fixes (01/16/2014)
  • 0.6: Click here to read this version's release notes.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.